The incident has been resolved - users may be required to refresh their browser cache if they're still experiencing issues. We apologize for the inconvenience.
Posted Mar 17, 2026 - 10:34 CET
Update
We are continuing to investigate this issue.
Posted Mar 17, 2026 - 09:59 CET
Investigating
We're currently seeing errors in some requests to the Portal's download page (where shared data can be accessed/data exports can be obtained). This may be related to the issue we had reported yesterday. The team is currently investigating the root cause and potential remediation steps.
Posted Mar 17, 2026 - 09:47 CET
This incident affected: Management Platform (efsta Portal).