Issues when editing company details in the Portal

Incident Report for efsta

Resolved

We've identified the issue and deployed a fix. The problem was caused by a misconfigured deployment - we'll continue working on our deployment gates to prevent incidents like this to happen in the future, and apologize for any inconvenience this may have caused.
Posted Mar 16, 2026 - 15:39 CET

Investigating

We've noticed an error spike in our Portal's monitoring. Most features of the Portal seem unaffected, but editing companies may currently not be possible for some users. Our engineering team is looking into the root cause, we will provide an update as soon as more information is available.
Posted Mar 16, 2026 - 15:29 CET
This incident affected: Management Platform (efsta Portal).